Upgrade Texlive from 2008 to 2010 with CJK

While upgrading the TexLive version from 2008 to 2010 in the box of ‘par’, I’ve encounter some problem of related packages: the CJK modular is the first. This blog post is to notice the solution I’ve tried where there is no guide from gentoo. The important notice is here: [solved] dev-texlive/texlive-latex-2011 fails to build. Although the discussion is about TexLive 2011, it is useful for debugging.

The steps for me to upgrade TexLive is simple: # emerge -uDN world. But I notice the error messages while compiling:

#########################################################
fmtutil: Error! Not all formats have been built successfully.
Visit the log files in directory
/var/tmp/portage/dev-texlive/texlive-langcjk-2010/work/texmf-var/web2c
for details.
#########################################################

This is a summary of all `failed’ messages:
`ptex -ini -jobname=platex -progname=platex platex.ini’ failed
* ERROR: dev-texlive/texlive-langcjk-2010 failed (compile phase):
* failed to build format texmf/fmtutil/format.texlive-langcjk.cnf
*

With the reference, the solution I’ve tried is to unmerge all the TexLive related packages and reinstall them. And it is works. Here listing some commands I’ve use.

1
2
# emerge -C texlive-langcjk texlive-latex
# qlist -I texlive

The qlist command is included by portage-utils and can be used to check which packages are Installed and corresponded to the keywords. If it is useless after un-merge the two packages, trying to use the qlist to find out all packages related and un-merge them all. And then, with the # emerge --depclean and # revdep-rebuild, we can install TexLive in a nearly clean state.

Enjoy it. 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *